Upgrade debian jessie (8) to stretch (9)

Submitted by davide on Sat, 21/09/2019 - 11:42

Purtroppo qualche aggiornamento dei servizi (drupal, dokuwiki) forniti dalla macchina (virtualizzata), mi ha costretto ad un upgrade, che ancora non e` terminato, perche` dovrei arrivare alla Debian 10 (buster).

 

1. mysql

Questo e` stato il primo errore, che ho risolto con un semplice comando: mysql-upgrade

L'errore si manifestava chiaramente effettuando un dump dei database (per backup).

 

2. php

S'era probabilmente creata confusione fra la versione 5 e 7, dopo varie peripezie ho optato per una rimozione totale "apt-get --purge php*", ed una reinstallazione "apt-get install drupal7" (drupal che poi ho rimosso), che si e` reinstallato tutti i pacchetti php (php7) necessari, poi ne ho installato qualcun'altro che appariva negli errori dei log, usato da dokuwiki (ora non ricordo quali).

 

Come ho scritto all'inizio non e` finita, ma il sistema funziona per ora ;)